Editors

December 25, 2013   

These are my Atom and Sublime 3 Packages and Settings

I used these editors in the past, Atom, and Sublime. Now I am using VSCode

Here are my installed extensions for these editors.

VSCode, Visual Studio Code

awesome-vscode

  • Go
  • Vim
  • vscode-icons
  • markdownlint
  • gi

Atom

  • linter
  • linter-flake8
  • linter-csslint
  • linter-jshint
  • atom-beautify
  • autocomplete-python
  • python-isort
  • language-django
  • atom-minimap
  • merge-conflicts
  • editorconfig
  • remote-edit
  • go-plus
  • file-icons
  • python-yapf

Sublime 3

First install Package Control: https://sublime.wbond.net/

Install Packages:

  • SFTP
  • SideBarEnhancements
  • SublimeLinter
  • SublimeLinter-flake8
  • SublimeLinter-csslint
  • SublimeLinter-json
  • SublimeLinter-xmllint
  • SublimeLinter-jshint
  • requirementstxt

Install this:

  • Anaconda

Instead of these:

  • Python PEP8 Autoformat
  • All Autocomplete
  • SublimeCodeIntel

User Settings:

{
"color_scheme": "Packages/User/Monokai Bright (SL).tmTheme",
"font_size": 13.0,
"ignored_packages":
[
],
"translate_tabs_to_spaces": true,
"anaconda_linting": false
}

SublimeLinter user settings:

"flake8": {
    "@disable": false,
    "args": [],
    "builtins": "",
    "excludes": [],
    "ignore": "E501",
    "max-complexity": -1,
    "max-line-length": null,
    "select": ""
},

Theme:

  • Theme - Phoenix { “color_scheme”: “Packages/Theme - Phoenix/Color Scheme/Phoenix Dark Blue - Eighties.tmTheme”, “phoenix_color_expanded_folder”: true, “phoenix_dirty_bottom_bar_red”: true, “phoenix_highlight_current_tab”: true, “phoenix_solid_current_tab”: true, “phoenix_tabs_auto_width”: true, “theme”: “Phoenix Dark.sublime-theme” }

Ref: setting-up-sublime-text-for-python-development, Setting Up Sublime Text 3 for Full Stack Python Development



comments powered by Disqus